1. 问题描述

Maven打包报错jdk版本问题,1.5不支持diamond运算符,请使用source 7或更高版本以启用diamond运算符。

2. 解决方法

配置 pom.xml 中 Java 版本

方法一

<properties>
    <maven.compiler.source>1.8</maven.compiler.source>
    <maven.compiler.target>1.8</maven.compiler.target>
</properties>

方法二

<build>
    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <version>3.5.1</version>
            <configuration>
                <source>1.8</source>
                <target>1.8</target>
            </configuration>
        </plugin>
    </plugins>
</build>

参考:https://www.zhihu.com/question/56949122/answer/151025345